[colug-432] ubuntu headless install preseed problems

Rick Hornsby richardjhornsby at gmail.com
Thu Sep 18 01:34:01 EDT 2014

Basement server.  No monitor or keyboard and I’m too lazy to haul it all the way upstairs (jt is really heavy), or haul my good desktop LCD all the way down to the basement and all the way back upstairs.  So, trying to do a headless install of Ubuntu and it isn’t going well so far.  Frankly, everything I can find on Ubuntu’s site is either way more complicated than what I need or way out of date so that it doesn’t look anything like what I’m looking at in the 14.04 ISO.

I’m working with the netboot mini.iso image, and more or less following this (along with some other random documentation from Google’s lucky answer box)


I’m using vmware to test the ISO before burning a disc, and so that I can see what is happening i.e. if it is actually working.

Problem is that no matter what I do, I can’t get seem to get the installer to read or use the preseed file - either including it in the ISO (“/cdrom/preseed.cfg”) or putting it on an http server on the local network.  Every time, the installer stops on the very first step of what would be an interactive install and prompts for the install language.  I tried answering the first few questions to see if many the preseed file was just missing one or two things, but the installer seems to be oblivious.

This is my preseed.cfg file:

# Locale sets language and country.
d-i debian-installer/locale select en_US
# Keyboard selection.
d-i console-keymaps-at/keymap select us
d-i debconf/priority                   select critical
d-i auto-install/enabled               boolean true
d-i netcfg/choose_interface            select auto
d-i netcfg/get_hostname                string archer
d-i netcfg/get_domain		       string local
d-i network-console/password           password SECRET123
d-i network-console/password-again     password SECRET123
d-i preseed/early_command string anna-install network-console

and here’s what I have in the txt.cfg file for the netboot that is on the remastered ISO:

label netinstall
	kernel linux
	append vga=normal initrd=initrd.gz file=/cdrom/preseed.cfg preseed/url= console-setup/layoutcode=us console-setup/layout="U.S. English" console-setup/variantcode=intl countrychooser/country-name="United States" debian-installer/country=US languagechooser/language-name="English" languagechooser/language-name-fb="English" netcfg/get_hostname=archer mirror/http/countries=US mirror/http/hostname=us.archive.ubuntu.com DEBCONF_PRIORITY=critical interface=eth0 hostname=localhost domain=localdomain --

I’ve tried file=, preseed/file=, preseed/url= and nothing seems to work.  I know I have both file= and url/preseed=.  I was getting desperate.  I’m not seeing any requests in the apache log for the file, and everything goes by so fast in the console that I can’t tell if it is throwing any errors there - but I haven’t seen any.

Any thoughts or ideas?


More information about the colug-432 mailing list