[colug-432] rhel7 ovf -> virtual box, can't boot [solved]

Rick Hornsby richardjhornsby at gmail.com
Wed Apr 29 16:49:10 EDT 2015

Solved my own problem before sending this, but thought I’d share the solution just in case anyone else ran into it.  Couldn't find this answer anywhere, mostly picked up little clues and guessed.

== Problem:

Side note - this all seems to be okay with a RHEL6 guest.

I exported a working RHEL7 VM out of vCenter to an ovf.  There are no major changes from the ISO - mostly a few extra application type things installed.  I imported the ovf into VirtualBox, but can’t get it to boot properly.  Rescue mode works fine - but a normal boot does not.

After the grub prompt, the host sits there for a while (about 4 minutes), and then eventually I can see some text which says 

[ OK ] Reached target Basic System.
dracut-initqueue[some pid]: Warning: Could not boot.

Below that it lists the LVM-based filesystems and says it can’t find them, and drops me to a dracut(?) emergency prompt.

I’m looking at the file /run/initramfs/rdsosreport.txt and am not seeing anything prior to ‘Warning: could not boot’ that jumps out at me.

It appears that all of the filesystems mount in rescue mode (chosen from the grub menu) just fine.

== Solution:

Somehow the initramfs for the standard (non-rescue) kernel is messed up.  I ended up rebuilding it, and the host came up fine.  Have to use dracut to rebuild.  Because the system is booted in rescue mode to fix the problem, the initramfs image and kernel have to be specified

$ dracut -f /boot/initramfs-3.10.0-229.0.0.el7.x86_64.img 3.10.0-229.0.0.el7.x86_64 -v

Note the two arguments to -f:
 - path to the new initramfs file
 - just the name of the kernel

More information about the colug-432 mailing list