[colug-432] Grub 2.0

Travis Sidelinger travissidelinger at gmail.com
Mon Nov 21 09:49:48 EST 2011

Has anyone worked with GRUB 2.0 yet?
  # grub2-install --version
  grub-install (GNU GRUB 1.98

I've been trying to create a bootable USB drive with a variety of boot options

Some examples are:

menuentry "System Rescue CD 2.3.1 32bit" {
        loopback loop /boot/iso/systemrescuecd-x86-2.3.1.iso
        linux (loop)/isolinux/rescuecd root=auto init=/linuxrc
looptype=squashfs loop=(loop)/sysrc.dat
        initrd (loop)/isolinux/initram.igz

menuentry "VMWare Converter 4.3" {
        loopback loop /boot/iso/vmware_converter-4.3.iso
        set root=(loop)
        chainloader +1

menuentry "Darik's Boot and Nuke" {
        loopback loop /boot/iso/dban-2.2.6_i586.iso
        linux (loop)/DBAN.BZI

But I've run into a number of issues:

1. The menu never launches on it's own.  I have to type "configfile
/boot/grub/grub.cfg" and it will launch.
2. When an OS does boot, it always jumps into booting as if "Enter"
was pressed.  How can I get their menus to work?
3. I can't get "chainloader" to work at all.

I've even tried upgrading to version 1.99, but I get compile errors.

I'm about ready to give up and try using syslinux boot loader instead.


"A careful reading of history clearly demonstrates ...
that people don't read history carefully.”

“We can't solve problems by using the same kind of thinking we used
when we created them.”
—Albert Einstein

More information about the colug-432 mailing list