[colug-432] Aha...the wifi hardware is reportedly disabled

Dennis Reeder reeder1968 at gmail.com
Thu Nov 13 17:56:46 EST 2014

Wifi is hardware disabled

‎11-09-2013 06:43 AM

Hi there,

In my Yoga 2 pro, the Intel wireless-n 7260 chip is hardware disabled when
using linux.

I checked it with fedora, ubuntu and suse. The output of "rfkill list" is
always the same:

0: ideapad_wlan: Wireless LAN
 Soft blocked: no
 Hard blocked: yes

How do i unlock it?

I have a dual boot with ubuntu & win 8.1 right now.


Wifi is hardware disabled

‎11-11-2013 03:25 AM

For others with the same problem, here's how i solved it:

There is a module called "ideapad_laptop" that prevents the wifi module to

A good workaround is to disable that module by blacklisting it. This worked
for me with Ubuntu and Xubuntu. This guy
to have done the same thing on fedora.

Make a new file for your personal blacklist

$ sudo nano /etc/modprobe.d/myownblacklist.conf

 and add an entry for the module

blacklist ideapad_laptop

reboot and you are good to go!

To only disable the module without blacklisting it, do that:

sudo modprobe -r ideapad_laptop


So let me see if I understand this correctly.  I will fire up the Yoga.  It
will of course be running Mint.  Oh snap!  And then I will open up the
terminal window.  Am guessing it is pretty much identical to what I would
use on my Mac.  Then I would create the file for my personal blacklist per
the instrucitons above (per Michael).   And then I would, per his
instructions, add what he calls an entry for the module.   Module =
blacklist I am assuming.  Exit terminal.  Reboot Mr. Yoga and voila...I
should have working wireless.   OK that remains to be seen....but have I
correctly described what I am supposed to do?  TIA

oh yeah.  source:
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.colug.net/pipermail/colug-432/attachments/20141113/8aca6941/attachment.html 

More information about the colug-432 mailing list